Midnight Mansion Forums
http://www.actionsoft.com/forums/cgi-bin/yabb2/YaBB.pl
Discussions of approved MM2 custom mansions (Mac only) >> A Yellow Submarine >> Moving blocks - puzzle or bug?
http://www.actionsoft.com/forums/cgi-bin/yabb2/YaBB.pl?num=1311873725

Message started by oaktable on 29.07.2011 at 01:31:05

Title: Moving blocks - puzzle or bug?
Post by oaktable on 29.07.2011 at 01:31:05
I have been playing YS, thanks for all your hard work SandyBean.  The scenes are really clever and beautifully made.

In at least three different places, it seems that there is a moving block that you absolutely need to proceed further, and if you accidentally trigger it (or trigger it and then fall off) you have no option but to start over from the last save because, even though the block's movement is repeated (once) if you leave and re-enter a room, you re-enter at a point that is too far away to get to the moving block.  One strike and you're out.  Having missed each of these blocks after making a lot of progress (thus wiping that progress out because you have to start over) it is intensely frustrating, to the point that, having encountered the third such block this morning, I have given up.  Is this just me, or is it  :-/a bug, or is there some workaround or puzzle I am missing?

I am speaking of the brown block that lifts you from the upper landing to the next level in 15488   ; the hidden white block that lifts you to the next level in 15095; and the horizontally moving block next the vine in 14692.  Each of these appears and moves once and once only, when triggered, unless you leave the room; but when you re-enter it is impossible (not difficult - impossible) to get to the already-moving block in time for its once-daily departure.   :-/

Title: Re: Moving blocks - puzzle or bug?
Post by josephine on 29.07.2011 at 16:56:28
Hi oaktable-

15488: that happened to me once during beta testing but then never again. Not sure.

15095 and 14692: these are harder jumps but the platforms should keep appearing once you find the secret triggers (whether you leave the room or not.)

SandyBean or beta testers??

Title: Re: Moving blocks - puzzle or bug?
Post by mapman on 29.07.2011 at 17:28:05
14692, 15095, 15488 - I didn't encounter any problems with these rooms during beta testing.

I've just downloaded the released version of the mansion and tested them in the Mansion Level Builder. 14692 and 15095 seem to work fine.

I had the same problem as oaktable in 15488. The upper brown block appears and takes you up to 15288 if you jump on it - but that presupposes that you know it's there! If you ride it down again it disappears and Jack is left in 15488.

Title: Re: Moving blocks - puzzle or bug?
Post by oaktable on 29.07.2011 at 22:11:08
Thank you very much for your replies!  Very odd - the problem definitely exists in the version I have downloaded, in all three rooms mentioned.  Perhaps I need to re-download the game completely?

Title: Re: Moving blocks - puzzle or bug?
Post by SandyBean on 30.07.2011 at 09:08:01
Hi oaktable,

I apologize for the delay in responding, it's been a frantic, and harrowing couple of days with our beloved dog Murphy having complicated surgery.  Thank you very much Josephine and Mapman for taking a look at things.

Your frustration is totally understandable, and for sure my Jack would be really upset if he only got one chance at a moving block, and even at a top run, couldn't possibly get there in time !!! [smiley=undecided.gif]

After checking and rechecking the three rooms in the builder, I cannot replicate this problem in these three rooms.  In 15488, on the top wooden staircase moving block, Jack does need to re-enter the room from one of the two choices below, and this was intended, but the other moving blocks you mention in 15095 and 14692 seem to be reappearing consistently for me in the builder. 

I would suggest re downloading the mansion and see if this fixes the glitch.  Your saves will be kept, so you can start where you wish.  Would be good to know if anyone else has had this problem.

Over the next little while, I will play the mansion in the version that was uploaded to MM, and see if I can find anything odd.

Thanks so much,  and crossing my fingers, and Jack's toes, that re uploading will help!

SandyBean  [smiley=2vrolijk_08.gif] 






Title: Re: Moving blocks - puzzle or bug?
Post by oaktable on 01.08.2011 at 02:57:16
Thanks SandyBean - I'll give that a try.  I hope all is well with the pooch.

Title: Re: Moving blocks - puzzle or bug?
Post by SandyBean on 01.08.2011 at 11:28:20
Thanks so much Oaktable, things are still pretty hectic with our dog Murphy as my hubby and I  try to adjust to the round the clock care he needs.

Just wondering if anyone else is having troubles (and also good to hear from people that they are working normally) with any moving blocks not performing as usual (specifically Rm #'s 15488, 15095 or 14692).  They should all keep moving once triggered, and for sure re-animate once you leave the room and come back. 

Thanks !
SandyBean  [smiley=2vrolijk_08.gif]


Title: Re: Moving blocks - puzzle or bug?
Post by Veronika on 01.08.2011 at 19:53:11
Hello SandyBean. First: a really cool mansion I love it! ;)
But I, too have serious problems with moving blocks. Not just in the rooms mentioned before ( 15488, 15095 etc ) but EVERY platform that is moving between the rooms is a problem ( NOT the bat ones, those work fine it's just the 'regular' blocks that takes you from one room to another) Every time the platform just goes to the next room once, so If you can't catch it you're done...
I downloaded the mansion one more time, the glitch is still here and also all my previous saves very erased ( well not erased they just couldn't be opened )   so I had to start again.
I'm playing on Mac. Hope  we can figure it out what's happening. I do like this mansion but in the current state is just not playable  :'( 

Title: Re: Moving blocks - puzzle or bug?
Post by MTGA on 01.08.2011 at 21:19:41
fyi - i did not have any problems with the three triggered moving blocks.

Title: Re: Moving blocks - puzzle or bug?
Post by SandyBean on 02.08.2011 at 03:49:12
OK, this is totally weird  [smiley=shocked.gif]

Veronika, thanks for explaining really well what you are encountering.  So this is happening for some people for sure on the moving blocks and for you on Every moving block !. 

I have no clue what's going on.  I'm not hugely computer savvy, and don't understand why for some the moving blocks are working ok, not for others, and I apologize for not knowing how to fix it immediately.   :question


I've not yet had time to play the mansion in game mode from MM download, but I will ask for help from the beta testers also on this.  I have gone into the MM downloaded version in the builder, and they work properly. Still dealing with a very time consuming recuperating dog who's not giving me a moment's rest !  [smiley=cheesy.gif]


Hopefully we can get this resolved, I can understand how it would be frustrating, and it really is a smoothly flowing mansion but would not be with this glitch  :-/


Thanks for your input and patience !  Also if ANYBODY has any advice or suggestions as to what might be going on, please feel free to share  [smiley=engel017.gif]

SandyBean  [smiley=2vrolijk_08.gif]

Title: Re: Moving blocks - puzzle or bug?
Post by josephine on 02.08.2011 at 10:08:01
This is so weird! I'll download the latest version and try playing it on a different computer to see if this happens.

SandyBean- I hope your puppy is OK  :-*

Title: Re: Moving blocks - puzzle or bug?
Post by Veronika on 03.08.2011 at 01:10:31
Don't worry SandyBean I'm sure one of the admins  here will recognize the problem ( hopefully  ;)
This glitch just proves  that you've build such a great mansion that we want to play it no matter If we get stuck in every other room  ;D

Hope the puppy is better. xxx


Title: Re: Moving blocks - puzzle or bug?
Post by brell on 03.08.2011 at 01:54:53

oaktable wrote on 29.07.2011 at 01:31:05:
I am speaking of the brown block that lifts you from the upper landing to the next level in 15488   ; the hidden white block that lifts you to the next level in 15095; and the horizontally moving block next the vine in 14692.  Each of these appears and moves once and once only, when triggered, unless you leave the room; but when you re-enter it is impossible (not difficult - impossible) to get to the already-moving block in time for its once-daily departure.   :-/


I checked in the level builder.  In 15095 and 14692 the T reveals the moving blocks, which are moving from the start.  The action is permanent, which means that even if Jack leaves the room and returns, the blocks will reappear and immediately move in the chosen direction.  I cannot see anything malfunctioning in these rooms.

In room 15488, on the other hand, the T activates the moving block, which was there from beginning but not moving.  There are two solutions:  1. Change the T from actvating to revealing and change the moving block to moveing from start.  2. Move the T slightly to the right.

Title: Re: Moving blocks - puzzle or bug?
Post by SandyBean on 04.08.2011 at 11:46:39
Thanks Brell for checking in the builder !  The brown floor coloured block in 15488 is designed so Jack will have to re-enter the room...there is more than one way for our curious Jacks !

I have downloaded again the mansion from here, and All works well for me in builder, and I'm just having a spare moment to start in game mode.  Only at save #2, but so far so good, all moving blocks working as designed in play mode. 

But, Mapman, one of the beta testers for AYS, suggested for folks to check that they are using the latest version of MM2 (1.0.2b).  If they aren't that might explain some of the anomalies.  Thanks so much Mapman for thinking of this ! 

Please post feedback of how things are going, and I'm soooo hoping to get this figured out, I may be biased, but from the mansion's three beta testers, I've heard that it's a great mansion to play.  I've also had feedback from some that the problem has disappeared, so very curious situation  :-?

Alas, I have to go tend to the puppy again, Murphy is way more demanding than any patient I ever had as a nurse !  Sending along a pic of yesterday's torture I put him through so I could complete the ramp he needs for going outside to do his business !  The poodle in the foreground is his energetic 'sister' Shasta !

Thanks so much guys,

SandyBean [smiley=2vrolijk_08.gif]
Puppy_picnic.jpg (47 KB | 324 )

Midnight Mansion Forums » Powered by YaBB 2.4!
YaBB © 2000-2009. All Rights Reserved.